花生壳内网穿透后无法使用onlyoffice(已解决)


#1

本人目前部署需求是seafile在局域网能够进行高速存储和拉取文件,外网能够使用onlyoffice随时进行轻办公协同!PS:因为金山文档出来的数据格式实在是让我这个Power bi 用户增添太多的麻烦!!最终考虑onlyoffice涉及的文本大小较小!花生壳专业版1兆的带宽应该能够解决问题了!本着技术不行数量来凑的原则,最后使用了两个域名来进行端口映射!一个域名对seafile的8000和8082端口进行映射!且布置dns服务进行域名本地化!另外一个域名专门进行onlyoffice的api调用,目前再本人技术程度上达到了能用的近况,如有大神能够有更好的解决办法请在帖子下留下解决办法!!!十分感谢:joy::joy::joy::joy:

按照官方文档在centos7 下的docker部署的onlyoffice,内网可正常访问与编辑。使用花生棒做内网穿透,使用外网80端口映射内网80端口后,外网下seafile的所有功能正常使用,onlyoffice无法使用显示一片空白!求大神解惑下!使用的http

Required for only office document server

map $http_x_forwarded_proto $the_scheme {
default $http_x_forwarded_proto;
“” $scheme;
}
map $http_x_forwarded_host $the_host {
default $http_x_forwarded_host;
“” $host;
}
map $http_upgrade $proxy_connection {
default upgrade;
“” close;
}

server
{
listen 80;
server_name 网址.cicp.那天;
index index.php index.html index.htm default.php default.htm default.html;
root /www/wwwroot/网址.cicp.那天;

#SSL-START SSL相关配置,请勿删除或修改下一行带注释的404规则
#error_page 404/404.html;

#SSL-END

#ERROR-PAGE-START  错误页配置,可以注释、删除或修改
#error_page 404 /404.html;
#error_page 502 /502.html;
#ERROR-PAGE-END

#PHP-INFO-START  PHP引用配置,可以注释或修改
#清理缓存规则

location ~ /purge(/.*) {
    proxy_cache_purge cache_one $host$1$is_args$args;
    #access_log  /www/wwwlogs/网址.cicp.那天_purge_cache.log;
}
#引用反向代理规则,注释后配置的反向代理将无效
include /www/server/panel/vhost/nginx/proxy/网址.cicp.那天/*.conf;

location /onlyofficeds/ {
# THIS ONE IS IMPORTANT ! - Trailing slash !
proxy_pass http://127.0.0.1:88/;
proxy_http_version 1.1;
client_max_body_size 100M; # Limit Document size to 100MB
proxy_read_timeout 3600s;
proxy_connect_timeout 3600s;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection $proxy_connection;
# THIS ONE IS IMPORTANT ! - Subfolder and NO trailing slash !
proxy_set_header X-Forwarded-Host $the_host/onlyofficeds;
proxy_set_header X-Forwarded-Proto $the_scheme;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
}

location /seafhttp {
rewrite ^/seafhttp(.*)$ $1 break;
proxy_pass http://127.0.0.1:8082;
client_max_body_size 0;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 36000s;
proxy_read_timeout 36000s;
proxy_send_timeout 36000s;
send_timeout 36000s;
}

include enable-php-00.conf;
#PHP-INFO-END

#REWRITE-START URL重写规则引用,修改后将导致面板设置的伪静态规则失效
include /www/server/panel/vhost/rewrite/网址.cicp.那天.conf;
#REWRITE-END

#禁止访问的文件或目录
location ~ ^/(\.user.ini|\.htaccess|\.git|\.svn|\.project|LICENSE|README.md)
{
    return 404;
}

#一键申请SSL证书验证目录相关设置
location ~ \.well-known{
    allow all;
}

access_log  /www/wwwlogs/网址.cicp.那天.log;
error_log  /www/wwwlogs/网址.cicp.那天.error.log;

}


#2

是否因为docker的onlyoffice 使用的为88端口!而花生壳在外网只映射了80端口的问题!求大神来解惑下!


#3

如果seafile 是外网的 onlyoffice 也要外网, 要不然请求发不过去


#4

已经做了反向代理,局域网内生效!完全不知道咋搞了


#5


这个是原先Seafile的onlyoffice配置,指向docker的onlyoffice的88端口。在此配置下局域网可正常使用!

这个是映射内网88端口后的外网网址作为接口地址,现在情况就是外网正常!内网无法使用!
现在的情况是否需要对nginx配置文档做修改????以下是现有反向代理设置!
025ac1994404d891019dd5c561b989a