安裝pro 試用版 安裝不了


#1

正在安裝seafile pro.
但運行到這步便動不了.
./setup-seafile-mysql.sh
我在想是不是跟權限有關。 密碼是正確的.


This is your configuration

server name:            CS-Seafile
server ip/domain:       cssvr1.xxxxx.com

seafile data dir:       /home/seafile/seafile-data
fileserver port:        8082

database:               use existing
ccnet database:         ccnet_server
seafile database:       seafile_server
seahub database:        seahub_server
database user:          seafile

Press ENTER to continue, or Ctrl-C to abort

Generating ccnet configuration …

done
Successly create configuration dir /home/seafile/ccnet.
Traceback (most recent call last):
File “setup-seafile-mysql.py”, line 1617, in
main()
File “setup-seafile-mysql.py”, line 1566, in main
ccnet_config.generate()
File “setup-seafile-mysql.py”, line 824, in generate
self.generate_db_conf()
File “setup-seafile-mysql.py”, line 841, in generate_db_conf
config.set(db_section, ‘PASSWD’, db_config.seafile_mysql_password)
File “/usr/lib/python3.8/configparser.py”, line 1201, in set
super().set(section, option, value)
File “/usr/lib/python3.8/configparser.py”, line 894, in set
value = self._interpolation.before_set(self, section, option,
File “/usr/lib/python3.8/configparser.py”, line 402, in before_set
raise ValueError("invalid interpolation syntax in %r at "
ValueError: invalid interpolation syntax in ‘Axj#$%yiho’ at position 5


#2

是的,我也测试过来,从7.1.6 PRO版开始,都会在数据库上遇到同样的问题

采用一键安装脚本方式布署完后,也会不创建用户名和密码,完成后也没有生成aio_seafile-server.log安装日志文件,如果用reset-admin.sh重置密码也会报错

暂时我还没找到解决方法


#3

謝. 那我裝回舊版本先試用.


#4

朋友,我成功将Seafile Pro 7.1.8安装在CentOS 8.2上面了,用的官方一键布署脚本,其中有错误的地方,我都在网上找到解决方法解决了


#5

我昨天在試. 7.1.8 跟ubuntu 20 但重裝了2次都有問題.

我轉用centos 7 & 7.1.3 便解決了.
因為時間太緊急, 所以先裝回舊版本給老闆測試

之後才慢慢試新版本