请按照以下模版详细描述您遇到的问题:
当前服务器版本
ubuntu24.04
部署/操作过程(请说明二进制部署/docker部署;出现错误的操作步骤)
docker-compose.yml
version: '3.7'
services:
db:
image: mariadb:10.11
container_name: mysql
restart: unless-stopped
environment:
- MYSQL_ROOT_PASSWORD=password
- MYSQL_LOG_CONSOLE=true
volumes:
- /opt/seafile/mysql/db:/var/lib/mysql
healthcheck:
test: ["CMD", "mysqladmin", "ping", "-h", "localhost", "-u", "root", "-p${MYSQL_ROOT_PASSWORD}"]
interval: 10s
timeout: 5s
retries: 5
networks:
- seafile-net
memcached:
image: memcached:1.6
container_name: memcached
restart: unless-stopped
entrypoint: memcached -m 256
networks:
- seafile-net
seafile:
image: seafileltd/seafile-mc:12.0-latest
container_name: seafile
restart: unless-stopped
volumes:
- /opt/seafile/data:/shared
environment:
- DB_HOST=db
- DB_ROOT_PASSWD=password
- SEAFILE_ADMIN_EMAIL=me@example.com
- SEAFILE_ADMIN_PASSWORD=asecret
- JWT_PRIVATE_KEY=XI1Hso95wl7F0ImA5VakpfpjoHs7t0wa
- SEAFILE_SERVER_PROTOCOL=https
- SEAFILE_SERVER_HOSTNAME=seafile.example.cn
depends_on:
db:
condition: service_healthy
memcached:
condition: service_started
networks:
- seafile-net
labels:
caddy: seafile.example.cn
caddy.tls: "/data/caddy/certs/cert.pem /data/caddy/certs/key.pem"
caddy.reverse_proxy: "{{upstreams 80}}"
caddy.encode: gzip
caddy:
image: lucaslorentz/caddy-docker-proxy:2.9-alpine
container_name: caddy
ports:
- "80:80"
- "443:443"
volumes:
- /var/run/docker.sock:/var/run/docker.sock
- /opt/seafile/caddy:/data/caddy
restart: unless-stopped
environment:
- CADDY_INGRESS_NETWORKS=seafile-net
networks:
- seafile-net
networks:
seafile-net:
name: seafile-net
root@seafile:~# docker ps -a
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
0eea600bd5b8 seafileltd/seafile-mc:12.0-latest "/sbin/my_init -- /s…" 2 weeks ago Up 2 weeks 80/tcp seafile
08fb51c25bf7 memcached:1.6 "memcached -m 256" 2 weeks ago Up 2 weeks 11211/tcp memcached
899d25663d8f mariadb:10.11 "docker-entrypoint.s…" 2 weeks ago Up 2 weeks (healthy) 3306/tcp mysql
7633fabdd86b lucaslorentz/caddy-docker-proxy:2.9-alpine "/bin/caddy docker-p…" 2 weeks ago Up 2 weeks 0.0.0.0:80->80/tcp, [::]:80->80/tcp, 0.0.0.0:443->443/tcp, [::]:443->443/tcp, 2019/tcp caddy
错误截图
错误日志
浏览器控制台错误信息(如果相关,请提供截图信息)
请求 URL:https://seafile.example.cn/api/v2.1/wiki2/3b950175-3216-486b-a386-0cd4363f9b36/pages/
请求方法:POST
状态代码:500 Internal Server Error
表单数据:page_name
Untitled
响应:{"error_msg":"Internal Server Error"}
控制台:
Failed to load resource: the server responded with a status of 500 ()
pages/:1 Failed to load resource: the server responded with a status of 500 ()
pages/:1 Failed to load resource: the server responded with a status of 500 ()
pages/:1 Failed to load resource: the server responded with a status of 500 ()
wiki2.38401870.js:2 POST https://seafile.example.cn/api/v2.1/wiki2/3b950175-3216-486b-a386-0cd4363f9b36/pages/ 500 (Internal Server Error)
(匿名) @ wiki2.38401870.js:2
xhr @ wiki2.38401870.js:2
Ot @ wiki2.38401870.js:2
value @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
p @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
r @ wiki2.38401870.js:2
s @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
value @ wiki2.38401870.js:2
value @ wiki2.38401870.js:2
n.handleAddNewPage @ wiki2.38401870.js:2
ze @ wiki2.38401870.js:2
Xe @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
Or @ wiki2.38401870.js:2
Sr @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
Me @ wiki2.38401870.js:2
(匿名) @ wiki2.38401870.js:2
Lr @ wiki2.38401870.js:2
$t @ wiki2.38401870.js:2
Zt @ wiki2.38401870.js:2
t.unstable_runWithPriority @ wiki2.38401870.js:2
Vi @ wiki2.38401870.js:2
Re @ wiki2.38401870.js:2
Qt @ wiki2.38401870.js:2
