升级seafile-server-6.2.5后启动报错(有哪位大神遇到过)


#1

系统环境如下:


执行启动脚本后报错如下:
[root@Seafile01 seafile-server-latest]# ./seafile.sh start

/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libccnet.so.0)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libsqlite3.so.0) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libssl.so.10)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.17' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libssl.so.10) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libcrypto.so.10)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.17' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libcrypto.so.10) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libevent-2.0.so.5)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.15' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libevent-2.0.so.5) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.17’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libevent-2.0.so.5)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libsearpc.so.1) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libgio-2.0.so.0)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libgobject-2.0.so.0) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libglib-2.0.so.0)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.15' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libglib-2.0.so.0) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.17’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libglib-2.0.so.0)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libjansson.so.4) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libz.so.1)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libgssapi_krb5.so.2) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libkrb5.so.3)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.16' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libkrb5.so.3) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.17’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libcom_err.so.2)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libk5crypto.so.3) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libffi.so.6)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libpcre.so.1) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.15’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libmount.so.1)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libmount.so.1) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.17’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libmount.so.1)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libkrb5support.so.0) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.14’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libkeyutils.so.1)
/server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: version GLIBC_2.14' not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libblkid.so.1) /server/tools/seafile-server-6.2.5/seafile/bin/seafile-controller: /lib64/libc.so.6: versionGLIBC_2.17’ not found (required by /server/tools/seafile-server-6.2.5/seafile/lib/libblkid.so.1)


#2

没有升级前版本是seafile-server-6.1.2,升级后出现启动报错。


#3

报错提示你了,你应该不是从6.2.4版本升级上来的吧,6.2.4以后的版本依赖有所变化,centos6.x系列的自带满足不了,可以备份数据以后安装centos7


#4

感谢回复。centos6.x内核版本低,已经解决升级内核版本。