Office Online 预览文件时出错的问题?求高人指点


#1

6.3版本 出错提示如下图:
%E5%9B%BE%E7%89%87

office online本身没问题都正常,
http://office online的ip/hosting/discovery

上面访问都没问题,而且我也用http://office online的ip/op/generate.aspx,访问自己的共享目录里的word文件也正常

这个是我的配置文件,和官方的一样:

Enable Office Online Server

ENABLE_OFFICE_WEB_APP = True

Url of Office Online Server’s discovery page

The discovery page tells Seafile how to interact with Office Online Server when view file online

You should change http://example.office-web-app.com to your actual Office Online Server server address

OFFICE_WEB_APP_BASE_URL = ‘http://office online的ip/hosting/discovery’

Expiration of WOPI access token

WOPI access token is a string used by Seafile to determine the file’s

identity and permissions when use Office Online Server view it online

And for security reason, this token should expire after a set time period

WOPI_ACCESS_TOKEN_EXPIRATION = 30 * 60 # seconds

List of file formats that you want to view through Office Online Server

You can change this value according to your preferences

And of course you should make sure your Office Online Server supports to preview

the files with the specified extensions

OFFICE_WEB_APP_FILE_EXTENSION = (‘ods’, ‘xls’, ‘xlsb’, ‘xlsm’, ‘xlsx’,‘ppsx’, ‘ppt’,
‘pptm’, ‘pptx’, ‘doc’, ‘docm’, ‘docx’)

Enable edit files through Office Online Server

ENABLE_OFFICE_WEB_APP_EDIT = True

types of files should be editable through Office Online Server

Note, Office Online Server 2016 is needed for editing docx

OFFICE_WEB_APP_EDIT_FILE_EXTENSION = (‘xlsx’, ‘pptx’, ‘docx’)

HTTPS authentication related (optional)

Server certificates

Path to a CA_BUNDLE file or directory with certificates of trusted CAs

NOTE: If set this setting to a directory, the directory must have been processed using the c_rehash utility supplied with OpenSSL.

OFFICE_WEB_APP_SERVER_CA = ‘/path/to/certfile’

Client certificates

You can specify a single file (containing the private key and the certificate) to use as client side certificate

OFFICE_WEB_APP_CLIENT_PEM = ‘path/to/client.pem’

or you can specify these two file path to use as client side certificate

OFFICE_WEB_APP_CLIENT_CERT = ‘path/to/client.cert’
OFFICE_WEB_APP_CLIENT_KEY = ‘path/to/client.key’


#2

看看8000端口是否OK


#3

防火墙都是关闭的。。。。。。。
另外我配置的onlyoffice就正常,同样的seafile服务器


#4

把 HTTPS authentication related (optional)后面的内容都删掉试试
我自己的情况是,oos上面的IIS部署了证书,seafile这个配置文件就不需要后面的https参数。


#5

高手,成功了,但是出现了另一个问题,当页面超时刷新后 会出现错误提示,如下图(没超时的情况下打开编辑都正常)
%E5%9B%BE%E7%89%87

我执行过Set-OfficeWebAppsFarm -OpenFromUrlEnabled:$true


#6

网页访问有效时间超时应该就没权限访问了吧?