seafile专业版在CentOS7开机自启动失败的解决方法


#1

参考官方文档方法一,需要修改几条参数,即可大功告成,本人Linux刚入门不久,请多指教,见下图
11
#1:首行默认如为bash,修改为sh
#2:使用【which python2.7】或【which python2.6】得到【python】路径
#:3:请将 user 改为你的Linux用户名
#:4:请将【seafile_dir】改为你的 Seafile 文件安装路径
#5:因为【seafile】启动需要依赖【mysql】数据库,所以开机后等待30s等【mysql】启动了,在运行【seafile】启动脚本,可自定义,根据系统启动快慢设定,能长点尽量长点,做到万无一失,特别电脑配置差,系统启动慢的,【seahub】前面的15S延时同理
#6:上方操作完毕,使用一条命令,如下
[root@WTMIS tmp]# chmod +x /etc/rc.d/rc.local

#7:最后记得将【mysqld】或【mariadb】设置开机启动,不然必定无法自启动【seafile】,命令如下:
[root@WTMIS ~]# systemctl enable mariadb.service

#8:最后【reboot】重启测试即可。